Michael/ 十一月 30, 2018/ Uncategory/ 0 comments

VSphere Cilent是一款虚拟平台工具,大多Win10系统在运行VSphere Cilent时都会被提示错误,无法正常运行,这是怎么回事?让小编来给大家分析分析。
原因分析:

Win10系统下无法运行VSphere Cilent,主要是由于Win10的.NET版本是3.5,而VSphere Cilent支持.NET2.0的。

解决方法:

  1. 从一台不是win10的安装了 Microsoft .NET 3.5 SP1的机器里,在这个路径:%SystemRoot%/Microsoft.NET/Framework/v2.0.5010210/,复制system.dll。
  2. 在安装路径里:C:/Program Files/VMware/Infrastructure/Virtual Infrastructure Client/Launcher/

如果是X64系统就是:C:/Program Files (x86)/VMware/Infrastructure/Virtual Infrastructure Client/Launcher/,建立一个文件夹:”Lib”, 将刚才的文件system.dll放在这里。

  1. 编辑C:/Program Files/VMware/Infrastructure/Virtual Infrastructure Client/Launcher/VpxClient.exe.config文件

加入:

  1. 在系统环境变量中建立一个新的环境变量:”DEVPATH”, 值为:C:/Program Files/VMware/Infrastructure/Virtual Infrastructure Client/Launcher/Lib

上述步骤设置完成之后,用户在Win10系统下重新打开VSphere Cilent就能正常运行了。

Share this Post

Leave a Comment

电子邮件地址不会被公开。

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> <pre class="">

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据